9880 chip problems

printer

#1

I put this on another forum as well so forgive the redundancy please…I don’t suppose anyone has discovered a way to turn of chip sensors in the 9880? I did it long ago on my old 9600, but have seen nothing indicating it can be done on the 9880. Once again I’m going in circles with chips, replacement chips, resetting chips, changing carts, looking inside with a dental mirror at the pins… etc etc and can find nothing wrong but no fix. The printer, out of the blue, decides one of the carts has a problem… If I could just turn off the sensors this craziness would be over… too much of this, and rush holiday jobs to get out the door.
Any input appreciated, thanks,
Tyler


#2

I wish it was possible, but my understanding is it’s only possible with the 4000 and 7600/9600 model printers… If you happen to find a magic solution, please share!

It’s unusual that you are experiencing such a high failure rate with these chips (I have been using these carts in our four 7880’s and two 9880’s for about five years and have only had to replace a total of 3 chips over that time). Chips are sensitive to electric/static shock, so could that be a factor in your situation? Do you have or have access to genuine Epson 7880/9880 chips? If so, you can use them on the refillable carts, and may have slightly better results (Epson chips are stronger, though still sensitive to static and can be shorted out).

Best regards~ Dana :slight_smile:


#3

the exact message is-
ink cartridge error
replace ink cartridge…

I’ve changed chips, then tried Epson cart, then reset them all and tried again, nada. And for some reason my resetters are going through batteries like crazy, or are just now dead. Since the current set of batteries are 1 day old I hesitate to try more, don’t see how they could die that fast. I have a new resetter ordered, and also some of the internal connectors as well. I need a Roland, been doing this stuff for years, seems to be my luck… I don’t know what more to suggest about why this happens to me.


#4

update, I just put chip #4, another Epson chip, in, and it’s working… I’m now suspect of the resetters… but am basically clueless as to what’s going on here. I’m printing though, just don’t know why.


#5

Thanks for the update. It is puzzling that your resetters (how many do you have?) are going thru batteries like crazy. In my experience (with dozens of different resetters), a set of 3 batteries should last at least a year if not two- though I have damaged a few resetters by accidentally dropping them onto the hardwood floor, and apparently broke something loose inside- the ones I haven’t dropped have been working well with their original batteries for years, and I would estimate hundreds of resets…

There have been a few rare situations over the years where it seems the resetters caused chip failure, though the resetter seemed to be working correctly (flashing red a few times then turning solid green). Also, occasionally a bad chip can cause the resetter to short out, but works again after removing + reinserting the batteries (resetting the resetter), then using on a different chip to test the resetter. If it works correctly on the second chip, but shorts out with the first, then something with the first chip is causing an issue with the resetter- this is resolved by replacing the chip.
In the situations where the resetter occasionally caused chip failure, once we determined the resetter was causing chip issues, a new resetter (and replacing the chips the first one fried) solved the issue.

I have also heard of the printer’s chip sensors wearing out over years, causing on and off sporadic chip errors.

I hope this is helpful, and sorry I don’t have the magic answer up my sleeve. Yes, the chip-less printers are nice for this reason, and we love our Roland for this and many other reasons.
All the best~ Dana :slight_smile:


#6

again… chip and resetter problems… questions-

  1. is the blinking red never changing to green an indication of a particular problem?
  2. How are the newer blue resetters opened for battery replacement?.. the older white ones had screws.

thanks, T

OK, so the screws to take the blue resetter apart are under the silver seal. I was able to replace the batteries and reset my cart. My older white resteers… one seems to be dead no matter what, no LEDs light, batteries don’t help… OK, end of life… but my other white one, seems to work but flashes red a few times and never goes to green, I’ve let it sit without batteries, and replaced them, and applied it to good chips, etc…curious if anyone knows of a cure for that. I’d prefer to have more then one here working…
Thanks


#7

Hi Tyler~

All chip resetters (both old and new) are held together with two tiny screws, which are often located under the label.
If you have replaced batteries in one of your resetters and it doesn’t do anything, then it may be corrosion on the contacts, a loose battery holder, or something not working (or broken) with the green computer board. You can check the function of the green board with batteries installed, by gently pressing it against a chip (without putting it back in the plastic case).
If your second resetter flashes red but never goes green, and you have already replaced the batteries and tested it on different chips- does it seem to still work and reset the chips, or are the chips not resetting as well? If the second one isn’t resetting chips, then unfortunately I don’t have any other suggestions, and think they must have been damaged or worn out (I know I destroyed one by dropping it on the hard wood studio floor, which must have broken a connection or something).

Best~ Dana