9880 capping station replacement

9880 has been dropping the #4 ink channel for awhile. Any excuse. Overnight, gone. Go to lunch, gone. Execute a standard cleaning - perfect. I decided to get a new capping station assembly and replace the old one. Included in replacing the capping station I disassembled the Flushing Box and replace the pad. Printer is loaded with flush. After reassembling the right hand side of the printer I ran an Initial Fill.The nozzle check was pitiful for all channels. When I pulled the Maintenance Tank expecting to see a decent amount of flush, there was none to speak of. After executing a Power Clean most nozzles on most channels returned, but not all. Repeated an Initial Fill and still no flush in the Maintenance Tank. The Flush Box pad is red with flush, the capping station pad is nearly spotless. I have new pad and wiper so I could clean and restore the original capping station then put it back in. Seems maybe the included pump is not working? Wondering if I missed something during installation. Only 2 electrical connections and 2 hoses - all connections were made. BTW, no pool of flush on the floor - whew.

bad pressure, bad damper to ink line screwing (too much and this happens). It could be all or some of these.


Thanks. I had checked the damper to ink line for being loose, hadn’t thought about it being too tight. Just rebuilt the original capping station and will put it back in. Have spare pumps from 9800 I recycled. Hoping those will make the new capping station actually function.


Did you get this problem resolved? I am having the same issue on a 7880 after doing the exact process you followed. I am seeing flush/ink on one of the tubes exiting the cleaning assembly into the waste tank but not the other. I also syringed the bottom of the dampers to make sure they were pulling ink correctly. And they are.

I did get it working, but don’t remember exactly how. The printer is still printing perfectly. Needs very little attention since to keep it going. Hopefully it will come to me, I know how frustrated I was.

I am thinking I found one of the hoses dropped off or was kinked. I do know I took the side cover off and worked it until I was certain everything was perfect. Didn’t replace the pump.

Thanks Don. If you recall anything else, drop a note here or please email me. My right cover is off as well. Checked the hoses on the back of the capping station: both good. Checked electrical connections: both good.

The “capping station being almost spotless” but the flushing box working perfectly is the odd thing I cannot resolve.

Did you discover that your dampers were on too tight? Do new dampers completely fill up with ink (the entire circular area)? Or just the filter area and channels? (If that makes sense).

And, of course, terrible nozzle checks, :-).

did check them by just a slight loosen and retighten, then made sure all of the dampers were seated and in proper place. That arrangement is not all that precise as I recall, leave a little wiggle.