7900 magenta cartridge not being recognized

printer

#1

Hi everyone (Dana, if you’re reading this, congratulations on the birth of your child!),

I am having an issue with cartridge recognition in my Epson 7900. I recently bought a set of 350ml carts for Piezo flushing my printer.

Everything during the prep and installation of the carts went smoothly, except with magenta. This cart isn’t being recognized by the printer. I tried ejecting and reinserting all of the carts a few times (3 or 4), making sure that they were pushed to the left as suggested by the manufacturer, still no luck.

Any other suggestions?
Thanks,
Jens


#2

Hi Jens,

Do you have the Epson Cartridge available to test operation of this position? It is possible it’s a faulty chip &
I see you purchased these carts about a month ago, if you can verify the operation of this channel with another cartridge it would indicate a faulty chip. In that case we will send you a replacement asap in the mail.

Kindly,
Kelly


#3

Hi Kelly,

Thanks for getting back to me. Yes, I have the OEM magenta cart. I inserted it and it was recognized, so it looks like it’s a chip issue.

I just placed an order for some 3800 carts and Piezo flush fluid (order conf. 972-SO30742663). It probably makes sense to include it with that shipment.

Cheers,
Jens


#4

Hi Jens~

Thanks for your note. I’m back from maternity leave, so checking emails and getting back into my normal routine.

I see a replacement VM chip was included in your last order, did the new chip resolve your error?

Please let me know.
Thanks and best regards~ Dana :slight_smile: