7880 - problem restoring parameters to new main board

7880

#1

Hi all (especially Dana, who has more experince with x880 printers than anyone I know …)

I’m trying to keep my 7880 running. After a year or more of continuous printhead problems, I replaced it, only to be confronted with the Error 0001001B - printhead temp warning. Somewhere in the process I saw an advice that the problem may be with the main board. I’d also been getting severe misfiring nozzle problems, so I replaced that too.

I’m running the Adjustment Program and associated tools via WIn 7 32 bit on a MacBook Pro with Bootcamp. I have the 7880 Field Repair Guide, and following the instructions for main board replacement, I was able to successfully back up the parameters using nvram.exe, but now after installing the new head, I’ve been able to load the firmware, but when I try to restore the parameters using nvram.exe, I get an error stating that “the printer is not ready”. (open nvram.exe, select printer & port, open backup file, but error occurs on write command)

My approach to problem solving is first to eliminate variables - and there’s a few here, so before getting into fine detail, which I’ll be happy to do if necessary, I’d be grateful if anyone has experience with and/or advice on the following:

Does anyone know what the vague “printer not ready” error actually means? It doesn’t seem to be a comms problem - just getting the Adjustment Program to talk to the printer has been a nightmare. I had plenty of comms errors until I worked out to update the USB drivers in my virtual Win OS. It looks to me to be referring to the state of the printer - but what exactly I have no idea.

Has anyone successfully used Win running on a Mac to support this kind of repair work? Should I be using a ‘real’ Win machine instead?

My printer is currently loaded with PZFlush, and has been throughout the whole head and board replacement process. On the one occasion some years ago when I had a “professional” technician do a service, I was already using ConeColor inks, and he told me that he could only run the Adjustment Program with original Epson ink carts in place. Does anyone know whether this is true? Or has anyone successfully used the Adjustment Program with CC inks or PZFlush loaded?

(As an aside, I’m located in Hong Kong, and I had my doubts about that technician anyway - apart from the language barrier - he spoke very little English, and I don’t speak Cantonese - the first thing he did was begin to remove the ink carts without releasing the pressure, and so sprayed ink all over my studio. Not impressed that he appeared not to even know that the 7880 is a pressurized system. On the other hand, being in HK gives me good, fast access to the Chinese market for replacement parts …)

So, any advice on these general questions would be appreciated. It’s frustrating that Epson only supply their support software for Win, but it is what it is.

Thanks!


#2

Are you in Serviceman Mode when attempting to write the parameters from the Adjustment Program? If not then, enter into the Serviceman Mode. Turn the printer ON while holding down the [Pause], [Menu >] and [Paper Feed (down) ].

Search online for a PDF download of the more thorough Epson Service Manual (476pp). It is a much better reference than the field guide for EPSON Stylus Pro 7400/7450/7800/7880/7880C 9400/9450/9800/9880/9880C repair procedures.


#4

I run the adjustment wizard (v.2.1.2) on a Mac using Win 8.1 running under Parallels. I can relate to your frustration of getting the program to recognize the printer at all. But once it does, all modules seem to work okay even with Cone carts filled with Piezoflush. I have replaced the print head on my 7880 but haven’t replaced the main board. Wish I could be more helpful.


#3

Thanks for your response. Yes, I’m in Serviceman mode. I also have the Service Manual in addition to the Field Repair Guide, and I’m following the instructions in both explicitly. The only things I’m aware of that I’m doing that is non-standard is using Win via Bootcamp on a MacBook, and possibly not having OEM ink carts in the printer. Hence my questions.


#5

Sorry for the late reply on this.

Printhead Temp Warnings (thermistor warnings) are due to just about only one thing: a miss-aligned or shorted (or wet) ribbon cable going into the printhead. You need a new ribbon cable and you need to make sure there is no shorted contact inside of the printhead board where the cable goes in as well.

best,
-Walker