7880 Ink Cartridge Error/Replace Cartridge

7880, Mac Pro (2009) running OS 10.11.5, using mixture of Cone & Epson inks for over a year. I replaced the waste ink thingy a month or so ago, and removed & shook all cartridges after that.

The Problem:
In middle of a batch print job on Epson Exhibition Canvas today, got an error msg saying, “Ink Cartridge Error Replace Cartridge” in the Photo Black slot, which has had a Cone cartridge for quite some time. The printer display shows a flashing X on this cartridge. I have tried turning printer off & on, removing/reinserting cartridge, removing roll paper, and replacing the Cone cart with an Epson T6031 photo black cartridge. The error remains. Pressing the left-right buttons has no effect.

Any suggestions greatly appreciated.


Eugene Norris 727 865 8518
876 Ponce de Leon Drive
Tierra Verde, FL 33715

Did you reset the cartridge?

If so, . .

Do you have another cartridge handy? (even one of another color). This chip can be used on the cartridge and then you can simply hit Pause when the printer says it’s non-genuine.


No, I’m not up to speed on resetting cartridge. As I mentioned, I did change the Cone cartridge for an Epson, but it made no difference.

Check in the ink bay to see if a sensor wire is bent out of whack (top back of the bay). These original sensors are incredibly fragile. The replacement ones sold by compassmicro.com are no longer wires but metal discs and are therefore much more resilient.


[QUOTE=walkerblackwell;11392]Check in the ink bay to see if a sensor wire is bent out of whack (top back of the bay). These original sensors are incredibly fragile. The replacement ones sold by compassmicro.com are no longer wires but metal discs and are therefore much more resilient.


A local repair tech says the chip reader might be bad, and the fix is to replace the entire ink well, for a lot of money. Is the thing you call a sensor the same thing as a chip reader? Any idea where I could find instructions or pictures?

You don’t need to replace the ink bay (epson repair guys always ay this). Just the chip sensor. That is like $1.50 at compassmicro

Also download the maintenance repair manual from 2manuals.


Hi, I have similar problem, also “Ink Cartridge Error Replace Cartridge” .7880. GO slot. Just started the printer and was running nozzle checks and cleaning cycles. I tried to reset the chip, bit the flashing light would become steady red and that is it.

Please advise

@nune. Does your chip resetter reset other carts?

i haven’t tried it, since all of them were new. Would you recommend to try it on the new cartridges?

would you recommend to test it on the new cartridges?

Yes. I would test the resetter on one new cartridge. If it works, than it’s the chip on the first cart. If it doesn’t work than it’s the chip resetter and possibly also the chip on the first cart.

One way to fix this is to simply put an OEM chip (any one from any x880 epson cartridge it doesn’t have to be the correct color) onto the IJM cartridge. The printer may say it’s not genuine but then you just hit pause and it should work.


tried few things- took out one of the new full cartridges from the printer, resetter worked on it as it should- few red blinks, then turned green. Tried to reset new empty IJM cartridge- few red blinks then nothing. Removed chip from the genuine 3880 , installed instead of the cart with problem, tried to reset it, resetter does not even blink red. What I am doing wrong?


tried few things:

  1. took out full IJM cartridge from the printer, resetter worked on it, as it should- few red blinks, then steady green.
  2. tried on the empty IJM, few red blinks, then nothing at all
  3. removed chip from the geniune 3880 , installed on the cart with the problem, resetter did not give any indication of life- no red, no green no nothing.
    What i am doing wrong?

update: resetter is fine.
chip from the 3880 is not getting reset though.
can i remove a chip from the empty IJM mate black and use it on the GO cartridge, or they need to be specific for every color ? If yes, I will need to purchase new one I guess

update. Ordered chips , changed the chip on the GO cartridge, problem is solved

:slight_smile: That is good.

Hi, I’m having a similar problem here.

Running Epson 9880 with a mix of conecolor and epson inks. When Photo Black (OEM) was almost empty, we run the black ink change. Everything went smoothly until we inserted the Conecolor Matte Black. The printer displayed “cartridge error”. We thought it was a chip error, so we reset it. Then inkjetmall kindly provided us with a new chip, but the issue was not resolved, the printer still displays “Cartridge error”. We do not have any black OEM chip to switch it because the photo black is now empty.

What should we do next?
Thanks in advance


Your issue is different. You are simply using the wrong chip (PK) in a printer that is set for MK ink.

You need to get a chip from us (an MK) one: Spare Reset Chip for our 7880, 9880 cart - Matte Black


Hi Walker, thanks for your answer.

We are using one of your MK chip and we tried to reset it also. At that point in the black ink change (PK to MK), does the printer want a PK or MK chip?

I’m not sure where you are in the process of switching however if you just want the printer to accept the MK chip go through this process:Black ink swap on the Epson 7880 and 9880

Make sure you check the delicate wires on the chip sensor (top right inside of the K channel in the ink bay) to ensure that no wire is bent. These are very fragile things that can easily bend. There are multiple posts on this forum about these contacts (with links to part supplies, etc).