7800 prints all black, nozzle check prints as dark bands


#1

A week ago my Epson 7800 worked perfectly, I made a dozen 17x22 prints. Today I went to do a nozzle check and, instead of the usual pattern, it printed two bands of dark stripes. I tried again with the same result, then turned it off and on, and tried yet again. Still just dark bands, so I tried to print an image. The entire sheet, except for the leading edge, came out completely black, dripping with ink, though I could just barely discern the outlines of the image under all that black ink.

Does anyone have any ideas what is going on? Thanks!


#2

I think you have a short in the ribbon cable going to head (or the head control board). This is causing all your black nozzles to fire across the entire printed sheet. I’ve seen this on the x800s in the past.

It’s not a fixable thing per-se. It would require a replacement of the head and control board etc.

best,
Walker


#3

Thanks Walker. I will call the local repair guy today. The head is only a couple of years old, I hope I don’t have to replace it…