7800 & 9800 - Ink Cartridge Error - 8 out of 9!

7800
9800
9880
7880

#1

I been trying every trick I know to get these things to work in both my 7800 & 9800 but so far have manage only a compliant Magenta cart. I started with the LB & LLB, filled, as the were next for replacement from the OEM’s but just got the “Ink Cartridge Error - Check Cartridge” not matter what. So I thought I’d go through them all with a reset and install with out filling. Nearly gave up with 2 to go then struck it lucky with the Magenta! Unlucky last Yellow failed also. What next?


#2

Anyone out there? At this point I’m not too sure that this is the correct place for some tech advice/help. Did I say something out of place?


#3

Hi Lynn~

I apologize, somehow I didn’t receive notification of your first message!

We have recently had a few 7800/9800 refill carts that seem to have the wrong chips attached from the manufacturer, so I suspect this is what is causing your error, and will send you a set of replacement chips right away. If you have Epson carts, you can easily transfer chips from the Epson carts to use on the refill carts by following the instructions below. Instructions for replacing refillable cartridge chips can be found here: http://www.inkjetmall.com/tech/content.php?139-How-to-replace-chips-on-LF-carts

Please let me know if you have questions, your results with the new chips, or if there’s anything else I can help you with.
Best regards~ Dana

[U][B]Attach Epson chips to refill cartridges:[/B][/U]
Before handling any chips (or really any electrical device for that matter), you should ground yourself and mindful of the clothing you wear, and if you’re working on carpet, etc… as static shock can destroy a chip.

Looking at the chip on the Epson cartridge, you will notice there are two small plastic points that hold the chip in place. Make a note as to which way the chip fits onto the cartridge so you can attach it to the refill cartridge in the same direction. Using a straight razor blade at an angle carefully cut the top of these two points off (be careful not to scratch the gold contacts), which will release the chip so you can carefully pry it off the cartridge using the edge of the blade. You can also use a sharp knife or something similar to pry the chip off the refill cartridge. You will notice the same two points on the refill cartridge where the chip goes (pry the chip off the refill cartridge before attaching the Epson chip in it’s place)- gently line up the Epson chip with these points and attach it to the refill cartridge by using single thickness (not foam or thick) double sided tape. Making sure your hands are clean and dry, press the chip to make sure it is tightly seated and [B]flat/flush [/B]on the cartridge. Now, using the chip resetter- reset the chip and insert the cartridge into your printer. [B]NOTE: Installing a cartridge without a chip, or with a crooked chip attached can damage the printer’s chip sensor- so always make sure cartridges have chips secured flat before installing cartridges[/B]


#4

Phew! Thanks Dana, have tried and fried a few chips already. Have learnt to be a bit more careful though. Thanks for your attention.


#5

You are very welcome Lynn, we’re here to help!

Please keep me posted, and let me know if there’s anything else I can help you with.
Best regards~ Dana :slight_smile:


#6

Received the the chips Dana - that’s the good news. Now they are still not recognised and comes up with a “invalid ink cartridge - non genuine cartridge fitted” message


#7

Hi Lynn~

That’s very bizarre! I double checked the chips we sent, and even checked the Epson Australia site to make sure the AU version 7800/9800 printers don’t use different carts/chips than the US model (which is true with some models- but not the 7800/9800). You are in fact using an Epson 7800/9800 printer model, and not a 7880/9880- correct?
The title of this tread says you’re having an error with 8 out of 9 carts- which one IS accepted by your printer?
Have you tried attaching chips from the Epson carts to your refillable carts and/or reinstalled the set of Epson carts to make sure your printer accepts them correctly?
Did you attach the replacement chips I sent making sure the correct color position is on the correct/matching color position cartridge, and the chips were attached flat/flush and in the correct orientation in the chip area of the carts?

Please let me know so I can help you resolve this issue and get back to happily printing.
Thanks and best regards~ Dana :slight_smile:


#8

Hi Dana

Please may I ask for your guidance?

I am in a spot with my Epson 7890.

I have not used it regularly enough and have been trying your cleaning cartridges for quite a while now - with no improvement

Then I removed the print head and soaked the bottom section in the solution for a while and also tried to clean it with distilled water - not much of an improvement

I suspect that I now need another print head, but once I had removed this one quite a few times, it shows print cartridge error, and wont let me print despite having tried both the cleaning and normal cartridges - reset et al

I am not sure whether I may have spilt some fluid onto the contacts of the head and maybe blown another section of the printer

My questions are:

  1. Do you know how to get past the issue of not accepting the cartridges?

  2. Where can I get another print head at a reasonable price - they seem to be selling for about 55% of a new machine? - Indonesia has some low cost ones - is that a bad idea?


#9

Unfortunately, the 7890/9890 and 7900/9900 are prone to print head problems (especially if they’re not used regularly), and they have very different print head technology that can not be easily cleaned like previous model printers. There is some very helpful (and funny) information about these models here: http://myx900.com/
Epson has made it very difficult and expensive for people to maintain their printers, and we have found replacement print heads for these models cost around $2,000 from China!!

After reviewing your order history, I see you’re using the 850ml model cartridges, which we have occasionally experienced chip read issues with due to physical cartridge fit. Below, I copied a related post from our forum, which I believe may resolve the issue you’re experiencing (the full thread can be found here: http://www.inkjetmall.com/tech/showthread.php?676-Epson-7900-ConeColor-Pro-inks)

“As you may be aware, we’ve had a few different cartridge designs for this printer model over the years (in search for the overall best cart), and we actually have a newer 350ml cart than the 850ml ones you have. The 850ml carts are great in many ways, and certainly fit/lock into the printer better than previous carts, but we started having an occasional fit issue with the last shipment, which effects the chip read, and I believe is what you’re experiencing. Unfortunately, the carriage manufacturer wasn’t able to offer us a satisfactory solution, so we continued searching for and testing other carts, which led us to the new 350ml carts we have. I can explain the issue that I believe you’re experiencing with the 850ml carts you have, and hopefully be able to get you happily printing. On top of the cartridge, where the chip is attached, some of the carts have a dip in the plastic, which can make the chip not have a good connection with the printer’s chip sensor. Raising the chip it’s self risks catching on the fragile sensor wires, so isn’t a safe fix. Several people have reported, and we confirmed in our testing, then taking a piece of typing paper about 4x6” and folding it lengthwise in half twice (so it makes a 1x6” strip), then placing it on the bottom of the cartridge bay while sliding the cartridge into place- this raises the cartridge up slightly, which is usually enough to make a good connection between the chip and chip sensor, and the carts/printer work great.”

I hope this helps.
Best regards~ Dana