4880 Won's accept cartridge

4880
4000
4800

#1

I just received my new cartridges, but one (so far) isn’t being accepted by the printer. I tried pushing it in further and adding a wedge underneath, but no luck (that trick worked with the yellow, but now the magenta won’t read). I ordered cartridges from Inkjet mall because the ones I had found on line have been causing my so many problems. But the cartridges and the problems are identical. What to do?

  • Steve

#2

Did you try putting the chip from your OEM cart onto the 4880 cart? They are interchangeable. I’ve run nearly 8 4800 and 4880 model printers with IJM carts successfully this way (pre being hired by IJM mind you).

-Walker


#3

I was running it that way previously. I had to push the cart in and hold it as it booted up. But I got the new carts so I wouldn’t have to do that. Now it won’t accept it, no matter what I do.

  • Steve

#4

Is there anything else I can try? I’m stuck in the middle of a power cleaning.


#5

The power cleaning is what moves the cartridge slightly. I recommend wedging [I]all[/I] of the cartridges, even the ones that are working during the power cleaning procedure.

I’ve used small flat-head screw drivers in the past for that.

//

Please private message me the details of what cartridge is funky and we’ll get a replacement out.

-Walker