3880 won't print on paper with a new Motherboard

I had to install a new motherboard on my Epson 3880. I’m able to run head cleanings and ink is getting to the print head. When I run a nozzle check both from my computer and the printer itself, it won’t print any ink on the paper or film. There are no errors on the printer. Any help is appreciated.

Most likely this is a problem with a ribbon cable going from the head to the motherboard.

-Walker

Thank you so much, I spent time researching that yesterday. I’ll purchase new cables.

I had the same problem last year when a new mother board was installed in my 3880. The Epson Repair Center did a reset of the motherboard and that solved the problem.

I’m researching how to do a reset. I don’t have a repair center near by.

Unfortunately, I can not be of much help as my 3880’s mother board was reset at the Epson Repair Facility in Massachusetts.

Can we assume that you followed the procedure in the Field Repair Guide? If so, did you perform all of the resetting steps on page 25 as shown in this screenshot?

Screenshot 2022-05-31 at 10.06.47 AM

There is additional information on these steps in the Service Manual.

If you don’t have one or the other of these, I am happy to share.

Keith

Thank you for this info. I have not updated the firmware. I’ll try this.

Shauna

I’m not a field service tech. Can you help me reset this printer. I have the reset program.

I would appreciate a copy of the service manual. I have been working on this printer for far too long. I just want to get it working.

Sorry I missed your responses earlier. Too many distractions in the world these days.

I’m not a field service tech either – just another printmaker who likes my 3880s and tries to keep them alive as long as possible. I have done some service procedures, such as replacing the ink supply assembly, on a 3880, but I have not replaced a motherboard.

Here’s a link to my Dropbox folder of 3880 service materials. Let me know if you have problems accessing it.

You didn’t exactly answer the question in my earlier post about whether you followed all of the steps on that page of the Field Repair Guide.

Keith

I did not reset the motherboard. I’m going to try that this evening.

Excellent – good luck - please let us know what happens.