3880 LC cartridge not reading

printer

#1

I’ve replaced 3 cartridges so far that have worked great. The 4th one is giving me problems. This is the error message: No Ink Cartridge - all cartridge positions are blinking with an x. I’ve researched here and have done the following: Reset the printer several times; Removed the chip setter and inspected/cleaned all of the gold contacts; Checked the pins on the chip setter - all equal length and spring back out when depressed; Checked the chip setter for the plastic tabs on the perimeter - all seem to be the same as a different chip setter from a different position that works; Tried a different Epson chip from a second spare original cartridge.

I can’t get it to register. If I push the cart in past the normal position the lcd indicates that the door is open instead of no ink cartridge. So, I pressed it in and put a small wedge in place to hold it there but when I closed the door then it errored on the maintenance tank - it’s a brand new oem tank. Tried to reset the printer again several times no luck.


#2

Do you have an Epson cartridge you can test in that position to verify operation?

We have had some complaints about the fit of some of these carts, sometimes if you push the cartridge up/down or side to side you can get it to read, please try and if you get it to read you can place a small paper wedge under the cartridge to create a good contact with the chip sensor.

When you say you reset the printer, what was the procedure you performed?


#3

I don’t have a Light Cyan cartridge oem but do have another color. Don’t know if that would work.
To reset the printer I pulled the maint tray and all of the carts, turned off power for ten minutes, power back on, replaced maint tray and shut door when prompted, then put carts in left to right in order. I did this in between each of the other things I tried ie cleaning the contacts.


#4

Another color will not work.

Please try moving the cart back and forth or side to side to see if you can get it to read.


#5

If i push in pretty hard the lcd message changes to Ink Cover Open. I wedged a shim to hold it in place, closed the cover, after it checks it comes back with replace maint cart message. After i pull out and replace the new oem maint cart and close the door, it shows some of the carts good and some of them x’d out flashing for a couple of seconds and then goes back to the message to replace maint cart.


#6

Please verify that all the chips are attached to the correct Carts, they will be labeled in writing on top of the control chip itself. Sometimes these carts come with the incorrect chip attached


#7

The chip in question isn’t legible. Must have rubbed off - just a few marks left but no words.


#8

Where did you purchase these cartridges, your order history only shows a purchase of 7800 cartridges?


#9

I found your order history, you were using the wrong customer ID, I changed it to the correct one.

I will send you a new LC control chip in the mail today, after receiving please perform the same reset procedure as before, let me know if it works for you.

Thanks,
Kelly


#10

That’s the cust id I was given by cust service via email.


#11

I will let you know when the chip arrives.


#12

Got the replacement chip last week and had a chance to install it yesterday. Looks like replacing the chip and wedging the cart in did the trick. Tried either way alone but didn’t work without doing both. Thanks for the quick response in sending out the chip.


#13

I’m having the same problem with the light magenta. Went to replace it yesterday. Everything seemed to go smoothly, but the printer displays the No Cartridge error. While the cover is open, if I push in gently on the cartridge, the message changes to Cover Open. However, no amount of wedging results in successful results. Also, the blinking symbol says LC in the display. Shouldn’t it say LM?


#14

hi mwgraves10~

I responded off list, but will copy/paste the response I sent for others to read. One important detail you included here, but not on your email is that you replaced the LM cartridge, but now your printer says “NO cartg” with the LC icon flashing. Have you been using a refill cart in the LC channel, and it’s been working well until you installed the LM cart? If so, does the error change or stay the same if you reinstall the Epson LM cart you were previously using?

After reviewing your order history, I see you purchased a set of refillable carts and inks for your Epson 3880 in March of this year.

The plastic base of every 3880 reset chip should have three small plastic tabs around the side that hold it onto the cartridge. If any of these tabs are broken or bent inward, the chip will not stay secured to the cartridge, therefore not have a good connection with the Epson chip underneath, which will cause an error. Also, on the back of every reset chip, there should be three metal pins that stick out and touch the Epson chip- the three pins should be equal length for proper contact with the Epson chip. Please check the plastic base to make sure there are three plastic tabs, and if they are all in place, gently bend them outward slightly to ensure they catch and hold onto the cartridge. Also check to make sure the three metal pins are present and equal length. On the front of the chips, please check the gold contacts to make sure nothing is on the contacts that would interfere with the printer’s ability to read it- if you see anything on the gold contacts, gently clean them with either an alcohol pad or pencil eraser. After checking all these things, push the reset chips back onto their corresponding cartridges and make sure they are pushed all the way onto the cart for a good connection with the Epson chip, then reinsert the cartridges into your printer and see how the printer responds.

Occasionally, a cartridge doesn’t fit perfectly into a printer, causing a cartridge error such as you’re experiencing. Most times, removing + reinserting the cartridge solves the problem, but sometimes people add a thin wedge of paper under the cartridge to push it up slightly, and a few people have reported they added a piece of folded masking tape to the front edge in the small rectangle notch in the top of the cart (where the printer latch holds the cart in place), to get a tight/good connection between the cartridge chip and printer’s chip sensor.

I hope this helps, please let me know if you have further questions or there’s anything else I can help you with.
Best regards~ Dana