3880 cartridge problem

printer

#1

I bought a set of your cartidges about 6 months ago. I successfully replaced two but I am having trouble with the third which is yellow. At first it wouldn’t register as in at all but after replacing all the carts a few times somehow I managed to get it to read and was able to make a few prints. I turned it off and then on again today and again the LCD is reading “no ink cartidges”. I followed some instructions I found on the forum removing all the carts and the waste cartidge, turned off the machine for 3 minutes and then after turning it on reinserted the waste cartidge and snapped in all of the cartidges. Now the lcd showed only the yellow was missing - but still no cuppie doll. I have very carefully followed your initial instructions and am quite certain that I did not damage the original epson chip which I laid as described under your reset chip. The three spring loaded prongs are all the same length. I have lightly abraded them with a very fine paper. The three plastic tabs are correctly holding down the reset chip. I have lightly gone over the reset chip with an eraser. Nothing has worked. I have noticed however that when I push the yellow cart further in or to the side it seems to read. Someone mentioned something about wedging.

What do you think is the problem and how can I reliably fix it?

I am coming up against an exhibition deadline and am based in Australia so I am starting to sweat it. Your help will be great appreciated.

Thanks,

Paul Harmon


#2

Hi Paul~

Thanks for providing such detailed information, and or already checking the cartridge chips. I apologize for not responding sooner, we are closed for holiday vacation, but I’m answering tech support from home a few hours a day.

From what you explain, it sounds like the yellow cartridge isn’t firing in the printer perfectly, which is causing the errors you’re experiencing. I have occasionally seen one position cause errors with other carts, or even the whole set. Maybe 4-5 carts out of thousands we’ve sold have had slightly imperfect fit, and displayed errors, but these situations were resolved by folding a small (like 4x3”) piece of typing paper a few times (to be about 1x3” folded), and place it [U]under[/U] the cartridge while pushing the cartridge into place, which slightly raises the cart and corrects for a slight off-fit.

Please give this a try and let me know your results, if you have questions, or there’s anything else I can help you with.
Best regards~ Dana :slight_smile:


#3

Hi - I am having the same difficulty with my epson 3880 magenta cartridge - though my printer has never recognized the cartridge (the 3 other replacement cartridges I purchase work fine) .
I have tried all the above described fixes - included trying the paper wedging with no positive results.
Perhaps it is a faulty chip?
Thanks, Ann


#4

Hi Ann~

After reviewing your order history, I see you purchased a 3800 magenta cartridge, which will not work in a 3880 printer. If you have a 3880 printer, then you will need to use a 3880 Vivid Magenta reset chip, which you can order and attach to your current cart, but you also have Magenta ink, and need [U]Vivid[/U] Magenta for the 3880 printer model. Please verify your printer model so I can help you get past this and back to happily printing.

Best regards~ Dana :slight_smile:


#5

Hi Dana ~
I do indeed have a 3880 ~ so I will need cartridge w/ chip and vivid magenta ink
Ann


#6

Ok, that explains why your printer isn’t accepting the cartridge! This is the cartridge and ink you’ll need for your 3880 printer: http://shopping.netsuite.com/s.nl/c.362672/it.A/id.5841/.f

Please let me know if you have further questions, or there’s anything else I can help you with.
Best regards~ Dana :slight_smile:


#7

Thanks Dana, I’ve just placed my order for the correct ink. Ann


#8

Excellent- that should do the trick :slight_smile: