3880 not reconizing carts, maintenance tank error

I have installed Piezography Pro inkset in my 3880. I am having two issues. I have searched the forums and have tried everything. First the printer isn’t reconizing four of the carts, MK, Lk, LLk and yellow. As soon as i shut the ink lid the Maintenance Tank error appears. So I reopnen the door on the Maintenance , reinstall maintenance cart (which is new). Then its says there is an ink error, reinstert carts and then shows that four aren’t reconized and then a few seconds later the maintenance tank error again. I have reset the printer numerous times. Checked all the carts, numerous times. Replaced one chip I thought was a bit bent, no luck. Taped carts, put paper under carts, nothing is working!

This printer was working flawlessly before this. Unfortunatly, I don’t have a full set of OEM carts to restest it since I removed the chips from most of them.

So bummed about this, any other advice?

Thanks,
Carl

So I removed the OEM chips from the Piezo carts and gently replaced them back into their original OEM carts. Then one by one put them back into the piezo carts and into the printer until I got the error. I discovered it was the LLK cart causing trouble. Funny thing is that the cart and reset chip were the flattest and looked better then any of the others.

So when all the Piezo carts are in except the OEM cart of LLK everything works. So is it just the Piezo cart-reset chip? Could it be the OEM chip? It is really amazing that one cart can throw everything out of whack, including the maintanence cart!

Walker, can you send me a new LLk reset chip? I don’t need a whole new cart right? Any thing else I should check.

Really feeling like a total idiot with this system, even though I have been a working professional photographer for over thirty years!
Carl

We’ll send a replacement LLK 3880 control chip.

best,
Walker