Epson 7900 set up

printer

#1

Setting up Epson 7900 with inkthrift inks got past cartridge not engaging problem, shifting cartridges to left so their recognized, now after several power cleans when I print job starts fine and then I lose the LLK channel


#2

Hi Planepics~

I’m sorry to hear you’re experiencing some issues with our refillable carts in your 7900, but am here to help!

Please answer a few questions to help me get a better understanding of your situation in order to resolve your issue and quickly get you back to happily printing.

  1. Do you currently have the full set of refillable carts filled with InkThrift ink installed in your 7900 printer?
  2. Did you remove air and prime cartridge exit channels with ink using the syringe and small plastic priming tip, syringe only, or a different method/tool?
  3. After installing the refillable carts, is your printer’s pressurization pump turning on more frequently than when the Epson carts were installed?
  4. Please remove the LLK refillable cartridge in question, and examine the cartridge carefully- is the exit channel filled with ink? Is any ink in the plastic body of the cart (outside the ink bag)?
  5. Are all other colors fully printing on the nozzle check?
  6. Is LLK fully printing on the nozzle check, then completely drops out while printing an image? If so, does it return easily after a regular cleaning cycle or two?
  7. Please open the front cover of your printer and examine the length of ink lines inside- are they all filled with ink, or is there any air inside?
  8. What ink/carts were previously installed in this printer prior to installing our refillable carts and InkThrift ink?
  9. Did you completely or partially fill the carts for the first time, before installing and doing “several power clean cycles”?
  10. About how many power clean cycles have you done since installing the refillable carts?

Let me know answers to the questions above, if you have questions or observations that may be helpful for fixing your issue, or if there’s anything else I can help you with.
Best regards~ Dana :slight_smile:


#3

Thank you very much for your help! The answers are as follows:

  1. Yes, I have the full set.
  2. Yes, I primed with the small plastic priming tips.
  3. No, I do not think so (re: pressure pump).
  4. The Exit channel is filled and there is no ink outside the bag. All of the other colors are fully printing.
  5. Yes.
  6. LLK is fully printing on the nozzle check after the power clean but it then drops off shortly after I begin printing a job.
  7. I am not familiar with the way the lines should look but 11 thinner lines look good, one thicker line in the middle is clear.
  8. OEM carts
  9. I completely filled the carts.
  10. I have done a dozen power clean cycles.

I run the printer all day, every day. I have not had the issue that others have had with the 7900 print head. It was printing fine with the Epson inks.

I just ran another power clean and a nozzle check it appears good. As I print it turns bad. The nozzle check lines are the tenth from the left. Does that correspond to Lt Lt Black?


#4

Here is more information -

I just ran a few prints and I am now getting banding.


#5

Thanks for the additional information, this is all very helpful. From left to right, the 10th position on the 7900/9900 nozzle check (manual, not auto) is VLM (left to right, color order is: C, O, Y, LC, K, VM, LK, G, LLK and VLM). Please confirm which color position you are having problems with so I can help (a scan or photo of the printed nozzle check and example print showing ink drop out may help clarify). If the problem is in fact the VLM position, please remove and check that cartridge, and let me know if ink is anywhere other than inside the internal ink bag, or if there are any obvious issues, so I can get this resolved for you.

Thanks- Dana


#6

[QUOTE=Dana-IJM;1361]Thanks for the additional information, this is all very helpful. From left to right, the 10th position on the 7900/9900 nozzle check (manual, not auto) is VLM (left to right, color order is: C, O, Y, LC, K, VM, LK, G, LLK and VLM). Please confirm which color position you are having problems with so I can help (a scan or photo of the printed nozzle check and example print showing ink drop out may help clarify). If the problem is in fact the VLM position, please remove and check that cartridge, and let me know if ink is anywhere other than inside the internal ink bag, or if there are any obvious issues, so I can get this resolved for you.

Thanks- Dana[/QUOTE]

Sorry internet slow, my mistake its the 9th position

I have removed refilled reprimed the LLK cartridge

how/where do I send photos to?


#7

I tried to upload pics, but wont upload


#8

Ok, thanks for confirming it is in fact the LLK position that keeps dropping out during printing.
You can upload photos here using the Basic Uploader tool, or email them to me at techsupport@inkjetmall.com if you have any trouble and I will post them for you.
We will send you a new LLK cartridge, assuming something undetermined is restricting flow with this cartridge.

Please let me know if you have questions, how things go with the new cartridge, or if there’s anything else we can help you with.
Best regards~ Dana :slight_smile:


#9

I just emailed you the photos. When will the cartridge ship? I NEED IT TOMORROW!


#10

I received the photos showing your LLK dropout, thanks. Your replacement LLK cartridge has been shipped, and you will receive it soon. I recommend you remove and keep the chip from the current LLK cartridge in case you need a new LLK chip in the future (we recommend everyone have a set of spare chips on hand, so they are prepared and don’t have any down time waiting for a new chip to arrive in the mail if they ever need to replace a chip).

Please let me know if you have questions, your results after installing the new cartridge, or if there’s anything else I can help you with.
Best regards~ Dana :slight_smile: